What’s Vulnerable › Vulnerabilities
CVE-2018-16515
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-18 · updated 2026-06-17
- Weakness: CWE-347
Description
Matrix Synapse before 0.33.3.1 allows remote attackers to spoof events and possibly have unspecified other impacts by leveraging improper transaction and event signature validation.
Affected products
- Debian Linux: 8.0
- matrix-org synapse: before 0.33.3.1 — fixed in 0.33.3.1
How to fix
Upgrade to a fixed version: matrix-org synapse 0.33.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/matrix-org/synapse/issues/3796#event-1833126269
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IRW7YR2H3ASUSYX4AO4KMY3FNVDNYW3P/
- https://matrix.org/blog/2018/09/06/critical-security-update-synapse-0-33-3-1/
- https://github.com/matrix-org/synapse/issues/3796#event-1833126269
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IRW7YR2H3ASUSYX4AO4KMY3FNVDNYW3P/
- https://matrix.org/blog/2018/09/06/critical-security-update-synapse-0-33-3-1/
Get alerted when CVE-2018-16515 or the next vulnerability affects your stack