What’s Vulnerable › Vulnerabilities
CVE-2018-16543
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-05 · updated 2026-06-17
Description
In Artifex Ghostscript before 9.24, gssetresolution and gsgetresolution allow attackers to have an unspecified impact.
Affected products
- Artifex Ghostscript: before 9.24 — fixed in 9.24
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.24. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=5b5536fa88a9e885032bc0df3852c3439399a5c0
- https://bugs.ghostscript.com/show_bug.cgi?id=699670
- https://lists.debian.org/debian-lts-announce/2018/09/msg00038.html
- https://security.gentoo.org/glsa/201811-12
- https://usn.ubuntu.com/3768-1/
- https://www.debian.org/security/2018/dsa-4288
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=5b5536fa88a9e885032bc0df3852c3439399a5c0
- https://bugs.ghostscript.com/show_bug.cgi?id=699670
- https://lists.debian.org/debian-lts-announce/2018/09/msg00038.html
- https://security.gentoo.org/glsa/201811-12
- https://usn.ubuntu.com/3768-1/
- https://www.debian.org/security/2018/dsa-4288
Get alerted when CVE-2018-16543 or the next vulnerability affects your stack