What’s Vulnerable › Vulnerabilities
CVE-2018-16555
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-13 · updated 2026-06-17
- Weakness: CWE-80
Description
A vulnerability has been identified in SCALANCE S602 (All versions < V4.0.1.1), SCALANCE S612 (All versions < V4.0.1.1), SCALANCE S623 (All versions < V4.0.1.1), SCALANCE S627-2M (All versions < V4.0.1.1). The integrated web server could allow Cross-Site Scripting (XSS) attacks if unsuspecting users are tricked into accessing a malicious link. User interaction is required for a successful exploitation. The user must be logged into the web interface in order for the exploitation to succeed. At the stage of publishing this security advisory no public exploitation is known.
Affected products
- Siemens Scalance S602 Firmware: before v4.0.1.1 — fixed in v4.0.1.1
- Siemens Scalance S612 Firmware: before 4.0.1.1 — fixed in 4.0.1.1
- Siemens Scalance S623 Firmware: before 4.0.1.1 — fixed in 4.0.1.1
- Siemens Scalance S627-2M Firmware: before 4.0.1.1 — fixed in 4.0.1.1
How to fix
Upgrade to a fixed version: Siemens Scalance S602 Firmware v4.0.1.1; Siemens Scalance S612 Firmware 4.0.1.1; Siemens Scalance S623 Firmware 4.0.1.1; Siemens Scalance S627-2M Firmware 4.0.1.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105937
- https://cert-portal.siemens.com/productcert/pdf/ssa-242982.pdf
- http://www.securityfocus.com/bid/105937
- https://cert-portal.siemens.com/productcert/pdf/ssa-242982.pdf
Get alerted when CVE-2018-16555 or the next vulnerability affects your stack