What’s Vulnerable › Vulnerabilities
CVE-2018-16587
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-28 · updated 2026-06-17
- Weakness: CWE-20
Description
In Open Ticket Request System (OTRS) 4.0.x before 4.0.32, 5.0.x before 5.0.30, and 6.0.x before 6.0.11, an attacker could send a malicious email to an OTRS system. If a user with admin permissions opens it, it causes deletions of arbitrary files that the OTRS web server user has write access to.
Affected products
- Debian Linux: 8.0, 9.0
- Otrs Open Ticket Request System: from 4.0.0 before 4.0.32; from 5.0.0 before 5.0.30; from 6.0.0 before 6.0.11 — fixed in 4.0.32, 5.0.30, 6.0.11
How to fix
Upgrade to a fixed version: Otrs Open Ticket Request System 4.0.32, 5.0.30, 6.0.11. Check the vendor advisory for mitigations.
References
- https://community.otrs.com/security-advisory-2018-04-security-update-for-otrs-framework/
- https://github.com/OTRS/otrs/commit/a4a1a01f84fac7ab032570ee50b660e2ebb15c01
- https://github.com/OTRS/otrs/commit/d8cae00b0f78c2a07bb10cedb817304139395843
- https://github.com/OTRS/otrs/commit/d9db0c6a15caafda7689320ecf61777993c33711
- https://lists.debian.org/debian-lts-announce/2018/09/msg00033.html
- https://www.debian.org/security/2018/dsa-4317
- https://community.otrs.com/security-advisory-2018-04-security-update-for-otrs-framework/
- https://github.com/OTRS/otrs/commit/a4a1a01f84fac7ab032570ee50b660e2ebb15c01
- https://github.com/OTRS/otrs/commit/d8cae00b0f78c2a07bb10cedb817304139395843
- https://github.com/OTRS/otrs/commit/d9db0c6a15caafda7689320ecf61777993c33711
- https://lists.debian.org/debian-lts-announce/2018/09/msg00033.html
- https://www.debian.org/security/2018/dsa-4317
Get alerted when CVE-2018-16587 or the next vulnerability affects your stack