What’s Vulnerable › Vulnerabilities
CVE-2018-16744
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-09-13 · updated 2026-06-17
- Weakness: CWE-78
Description
An issue was discovered in mgetty before 1.2.1. In fax_notify_mail() in faxrec.c, the mail_to parameter is not sanitized. It could allow for command injection if untrusted input can reach it, because popen is used.
Affected products
- mgetty: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: mgetty 1.2.1. Check the vendor advisory for mitigations.
References
- https://www.x41-dsec.de/lab/advisories/x41-2018-007-mgetty
- https://www.x41-dsec.de/lab/advisories/x41-2018-007-mgetty
Get alerted when CVE-2018-16744 or the next vulnerability affects your stack