What’s Vulnerable › Vulnerabilities

CVE-2018-16841

Description

Samba from version 4.3.0 and before versions 4.7.12, 4.8.7 and 4.9.3 are vulnerable to a denial of service. When configured to accept smart-card authentication, Samba's KDC will call talloc_free() twice on the same memory if the principal in a validly signed certificate does not match the principal in the AS-REQ. This is only possible after authentication with a trusted certificate. talloc is robust against further corruption from a double-free with talloc_free() and directly calls abort(), terminating the KDC process.

Affected products

How to fix

Upgrade to a fixed version: Samba 4.7.12, 4.8.7, 4.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-16841 or the next vulnerability affects your stack