What’s Vulnerable › Vulnerabilities
CVE-2018-16844
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-07 · updated 2026-06-17
- Weakness: CWE-400
Description
nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive CPU usage. This issue affects nginx compiled with the ngx_http_v2_module (not compiled by default) if the 'http2' option of the 'listen' directive is used in a configuration file.
Affected products
- Apple Xcode: before 13.0 — fixed in 13.0
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 9.0
- nginx: from 1.9.5 before 1.14.1; from 1.15.0 before 1.15.6 — fixed in 1.14.1, 1.15.6
How to fix
Upgrade to a fixed version: Apple Xcode 13.0; nginx 1.14.1, 1.15.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00035.html
- http://mailman.nginx.org/pipermail/nginx-announce/2018/000220.html
- http://seclists.org/fulldisclosure/2021/Sep/36
- http://www.securityfocus.com/bid/105868
- http://www.securitytracker.com/id/1042038
- https://access.redhat.com/errata/RHSA-2018:3680
- https://access.redhat.com/errata/RHSA-2018:3681
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16844
- https://support.apple.com/kb/HT212818
- https://usn.ubuntu.com/3812-1/
- https://www.debian.org/security/2018/dsa-4335
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00035.html
Get alerted when CVE-2018-16844 or the next vulnerability affects your stack