What’s Vulnerable › Vulnerabilities
CVE-2018-16845
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-07 · updated 2026-06-17
- Weakness: CWE-400
Description
nginx before versions 1.15.6, 1.14.1 has a vulnerability in the ngx_http_mp4_module, which might allow an attacker to cause infinite loop in a worker process, cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted mp4 file. The issue only affects nginx if it is built with the ngx_http_mp4_module (the module is not built by default) and the .mp4. directive is used in the configuration file. Further, the attack is only possible if an attacker is able to trigger processing of a specially crafted mp4 file with the ngx_http_mp4_module.
Affected products
- Apple Xcode: before 13.0 — fixed in 13.0
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- nginx: from 1.0.7 through 1.0.15; from 1.1.3 through 1.15.5
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: Apple Xcode 13.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00035.html
- http://mailman.nginx.org/pipermail/nginx-announce/2018/000221.html
- http://seclists.org/fulldisclosure/2021/Sep/36
- http://www.securityfocus.com/bid/105868
- http://www.securitytracker.com/id/1042039
- https://access.redhat.com/errata/RHSA-2018:3652
- https://access.redhat.com/errata/RHSA-2018:3653
- https://access.redhat.com/errata/RHSA-2018:3680
- https://access.redhat.com/errata/RHSA-2018:3681
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16845
- https://lists.debian.org/debian-lts-announce/2018/11/msg00010.html
- https://support.apple.com/kb/HT212818
Get alerted when CVE-2018-16845 or the next vulnerability affects your stack