What’s Vulnerable › Vulnerabilities
CVE-2018-16846
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-15 · updated 2026-06-17
- Weakness: CWE-770
Description
It was found in Ceph versions before 13.2.4 that authenticated ceph RGW users can cause a denial of service against OMAPs holding bucket indices.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.10, 19.04
- Debian Linux: 8.0, 9.0
- openSUSE Leap: 15.0
- ceph: before 13.2.4 — fixed in 13.2.4
- Red Hat Ceph Storage: 2.0, 3.0
- RedHat Enterprise Linux Server: 7.0
How to fix
Upgrade to a fixed version: ceph 13.2.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00100.html
- https://access.redhat.com/errata/RHSA-2019:2538
- https://access.redhat.com/errata/RHSA-2019:2541
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16846
- https://ceph.com/releases/13-2-4-mimic-released/
- https://lists.debian.org/debian-lts-announce/2019/03/msg00002.html
- https://lists.debian.org/debian-lts-announce/2021/08/msg00013.html
- https://usn.ubuntu.com/4035-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00100.html
- https://access.redhat.com/errata/RHSA-2019:2538
- https://access.redhat.com/errata/RHSA-2019:2541
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16846
Get alerted when CVE-2018-16846 or the next vulnerability affects your stack