What’s Vulnerable › Vulnerabilities
CVE-2018-16850
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-13 · updated 2026-06-17
- Weakness: CWE-89
Description
postgresql before versions 11.1, 10.6 is vulnerable to a to SQL injection in pg_upgrade and pg_dump via CREATE TRIGGER ... REFERENCING. Using a purpose-crafted trigger definition, an attacker can cause arbitrary SQL statements to run, with superuser privileges.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- PostgreSQL: from 10.0 before 10.6; from 11.0 before 11.1 — fixed in 10.6, 11.1
- Red Hat Enterprise Linux: 7.0, 7.4, 7.5, 7.6
How to fix
Upgrade to a fixed version: PostgreSQL 10.6, 11.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105923
- http://www.securitytracker.com/id/1042144
- https://access.redhat.com/errata/RHSA-2018:3757
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16850
- https://security.gentoo.org/glsa/201811-24
- https://usn.ubuntu.com/3818-1/
- https://www.postgresql.org/about/news/1905/
- http://www.securityfocus.com/bid/105923
- http://www.securitytracker.com/id/1042144
- https://access.redhat.com/errata/RHSA-2018:3757
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16850
- https://security.gentoo.org/glsa/201811-24
Get alerted when CVE-2018-16850 or the next vulnerability affects your stack