What’s Vulnerable › Vulnerabilities
CVE-2018-16851
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-28 · updated 2026-06-17
- Weakness: CWE-476
Description
Samba from version 4.0.0 and before versions 4.7.12, 4.8.7, 4.9.3 is vulnerable to a denial of service. During the processing of an LDAP search before Samba's AD DC returns the LDAP entries to the client, the entries are cached in a single memory object with a maximum size of 256MB. When this size is reached, the Samba process providing the LDAP service will follow the NULL pointer, terminating the process. There is no further vulnerability associated with this issue, merely a denial of service.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Samba: from 4.0.0 before 4.7.12; from 4.8.0 before 4.8.7; from 4.9.0 before 4.9.3 — fixed in 4.7.12, 4.8.7, 4.9.3
How to fix
Upgrade to a fixed version: Samba 4.7.12, 4.8.7, 4.9.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106027
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16851
- https://lists.debian.org/debian-lts-announce/2018/12/msg00005.html
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20181127-0001/
- https://usn.ubuntu.com/3827-1/
- https://usn.ubuntu.com/3827-2/
- https://www.debian.org/security/2018/dsa-4345
- https://www.samba.org/samba/security/CVE-2018-16851.html
- http://www.securityfocus.com/bid/106027
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16851
- https://lists.debian.org/debian-lts-announce/2018/12/msg00005.html
Get alerted when CVE-2018-16851 or the next vulnerability affects your stack