What’s Vulnerable › Vulnerabilities
CVE-2018-16853
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-28 · updated 2026-06-17
- Weakness: CWE-400
Description
Samba from version 4.7.0 has a vulnerability that allows a user in a Samba AD domain to crash the KDC when Samba is built in the non-default MIT Kerberos configuration. With this advisory the Samba Team clarify that the MIT Kerberos build of the Samba AD DC is considered experimental. Therefore the Samba Team will not issue security patches for this configuration. Additionally, Samba 4.7.12, 4.8.7 and 4.9.3 have been issued as security releases to prevent building of the AD DC with MIT Kerberos unless --with-experimental-mit-ad-dc is specified to the configure command.
Affected products
- Samba: from 4.7.0 before 4.7.12; from 4.8.0 before 4.8.7; from 4.9.0 before 4.9.3 — fixed in 4.7.12, 4.8.7, 4.9.3
How to fix
Upgrade to a fixed version: Samba 4.7.12, 4.8.7, 4.9.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106026
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16853
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20181127-0001/
- https://www.samba.org/samba/security/CVE-2018-16853.html
- http://www.securityfocus.com/bid/106026
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16853
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20181127-0001/
- https://www.samba.org/samba/security/CVE-2018-16853.html
Get alerted when CVE-2018-16853 or the next vulnerability affects your stack