What’s Vulnerable › Vulnerabilities
CVE-2018-16854
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-26 · updated 2026-06-17
- Weakness: CWE-352
Description
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
Affected products
- Moodle: through 3.0.10; from 3.1.0 before 3.1.15; from 3.3.0 before 3.3.9; from 3.4.0 before 3.4.6; from 3.5.0 before 3.5.3 — fixed in 3.1.15, 3.3.9, 3.4.6, 3.5.3
How to fix
Upgrade to a fixed version: Moodle 3.1.15, 3.3.9, 3.4.6, 3.5.3. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-63183
- http://www.securityfocus.com/bid/106017
- http://www.securitytracker.com/id/1042154
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16854
- https://moodle.org/mod/forum/discuss.php?d=378731
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-63183
- http://www.securityfocus.com/bid/106017
- http://www.securitytracker.com/id/1042154
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16854
- https://moodle.org/mod/forum/discuss.php?d=378731
Get alerted when CVE-2018-16854 or the next vulnerability affects your stack