What’s Vulnerable › Vulnerabilities
CVE-2018-16858
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 67.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-25 · updated 2026-06-17
- Weakness: CWE-356
Description
It was found that libreoffice before versions 6.0.7 and 6.1.3 was vulnerable to a directory traversal attack which could be used to execute arbitrary macros bundled with a document. An attacker could craft a document, which when opened by LibreOffice, would execute a Python method from a script in any arbitrary file system location, specified relative to the LibreOffice install location.
Affected products
- The Document Foundation LibreOffice: before 6.0.7; from 6.1.0 before 6.1.3 — fixed in 6.0.7, 6.1.3
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 6.0.7, 6.1.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00059.html
- http://packetstormsecurity.com/files/152560/LibreOffice-Macro-Code-Execution.html
- http://www.rapid7.com/db/modules/exploit/multi/fileformat/libreoffice_macro_exec
- https://access.redhat.com/errata/RHSA-2019:2130
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16858
- https://seclists.org/bugtraq/2019/Aug/28
- https://www.exploit-db.com/exploits/46727/
- https://www.libreoffice.org/about-us/security/advisories/cve-2018-16858/
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00059.html
- http://packetstormsecurity.com/files/152560/LibreOffice-Macro-Code-Execution.html
- http://www.rapid7.com/db/modules/exploit/multi/fileformat/libreoffice_macro_exec
- https://access.redhat.com/errata/RHSA-2019:2130
Get alerted when CVE-2018-16858 or the next vulnerability affects your stack