What’s Vulnerable › Vulnerabilities
CVE-2018-16859
- Severity: medium (CVSS 4.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-29 · updated 2026-06-17
- Weakness: CWE-532
Description
Execution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' passwords to appear in EventLogs in plaintext. A local user with administrator privileges on the machine can view these logs and discover the plaintext password. Ansible Engine 2.8 and older are believed to be vulnerable.
Affected products
- RedHat Ansible Engine: before 2.5.13; from 2.6.0 before 2.6.10; from 2.7.0 before 2.7.4; from 2.7.5 through 2.8 — fixed in 2.5.13, 2.6.10, 2.7.4
How to fix
Upgrade to a fixed version: RedHat Ansible Engine 2.5.13, 2.6.10, 2.7.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00020.html
- http://www.securityfocus.com/bid/106004
- https://access.redhat.com/errata/RHSA-2018:3770
- https://access.redhat.com/errata/RHSA-2018:3771
- https://access.redhat.com/errata/RHSA-2018:3772
- https://access.redhat.com/errata/RHSA-2018:3773
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16859
- https://github.com/ansible/ansible/pull/49142
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html
Get alerted when CVE-2018-16859 or the next vulnerability affects your stack