What’s Vulnerable › Vulnerabilities
CVE-2018-16861
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-07 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) flaw was found in the foreman component of satellite. An attacker with privilege to create entries using the Hosts, Monitor, Infrastructure, or Administer Menus is able to execute a XSS attacks against other users, possibly leading to malicious code execution and extraction of the anti-CSRF token of higher privileged users. Foreman before 1.18.3, 1.19.1, and 1.20.0 are vulnerable.
Affected products
- foreman: before 1.18.3; from 1.19.0 before 1.19.1; 1.20.0-rc1, 1.20.0-rc2 — fixed in 1.18.3, 1.19.1
How to fix
Upgrade to a fixed version: foreman 1.18.3, 1.19.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:1222
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16861
- https://access.redhat.com/errata/RHSA-2019:1222
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16861
Get alerted when CVE-2018-16861 or the next vulnerability affects your stack