What’s Vulnerable › Vulnerabilities
CVE-2018-16870
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-03 · updated 2026-06-17
- Weakness: CWE-200
Description
It was found that wolfssl before 3.15.7 is vulnerable to a new variant of the Bleichenbacher attack to perform downgrade attacks against TLS. This may lead to leakage of sensible data.
Affected products
- wolfSSL: before 3.15.7 — fixed in 3.15.7
How to fix
Upgrade to a fixed version: wolfSSL 3.15.7. Check the vendor advisory for mitigations.
References
- http://cat.eyalro.net/
- https://github.com/wolfSSL/wolfssl/pull/1950
- http://cat.eyalro.net/
- https://github.com/wolfSSL/wolfssl/pull/1950
Get alerted when CVE-2018-16870 or the next vulnerability affects your stack