What’s Vulnerable › Vulnerabilities
CVE-2018-16876
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-03 · updated 2026-06-17
- Weakness: CWE-200
Description
ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04
- Debian Linux: 9.0
- Red Hat Ansible: from 2.5.0 before 2.5.14; from 2.6.0 before 2.6.11; from 2.7.0 before 2.7.5 — fixed in 2.5.14, 2.6.11, 2.7.5
- RedHat Ansible Engine: 2.0, 2.5, 2.6, 2.7
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
- OpenStack: 14
- SUSE Package Hub: all versions
How to fix
Upgrade to a fixed version: Red Hat Ansible 2.5.14, 2.6.11, 2.7.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00020.html
- http://www.securityfocus.com/bid/106225
- https://access.redhat.com/errata/RHSA-2018:3835
- https://access.redhat.com/errata/RHSA-2018:3836
- https://access.redhat.com/errata/RHSA-2018:3837
- https://access.redhat.com/errata/RHSA-2018:3838
- https://access.redhat.com/errata/RHSA-2019:0564
- https://access.redhat.com/errata/RHSA-2019:0590
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16876
- https://github.com/ansible/ansible/pull/49569
Get alerted when CVE-2018-16876 or the next vulnerability affects your stack