What’s Vulnerable › Vulnerabilities
CVE-2018-16880
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-29 · updated 2026-06-17
- Weakness: CWE-787
Description
A flaw was found in the Linux kernel's handle_rx() function in the [vhost_net] driver. A malicious virtual guest, under specific conditions, can trigger an out-of-bounds write in a kmalloc-8 slab on a virtual host which may lead to a kernel memory corruption and a system panic. Due to the nature of the flaw, privilege escalation cannot be fully ruled out. Versions from v4.16 and newer are vulnerable.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- Linux kernel: from 4.16 before 4.19.20; from 4.20 before 4.20.7 — fixed in 4.19.20, 4.20.7
How to fix
Upgrade to a fixed version: Linux kernel 4.19.20, 4.20.7. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00037.html
- http://www.securityfocus.com/bid/106735
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16880
- https://support.f5.com/csp/article/K03593314
- https://usn.ubuntu.com/3903-1/
- https://usn.ubuntu.com/3903-2/
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00037.html
- http://www.securityfocus.com/bid/106735
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16880
- https://support.f5.com/csp/article/K03593314
- https://usn.ubuntu.com/3903-1/
- https://usn.ubuntu.com/3903-2/
Get alerted when CVE-2018-16880 or the next vulnerability affects your stack