What’s Vulnerable › Vulnerabilities
CVE-2018-16881
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-25 · updated 2026-06-17
- Weakness: CWE-190
Description
A denial of service vulnerability was found in rsyslog in the imptcp module. An attacker could send a specially crafted message to the imptcp socket, which would cause rsyslog to crash. Versions before 8.27.0 are vulnerable.
Affected products
- Debian Linux: 9.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux For Ibm Z Systems: 7.0
- RedHat Enterprise Linux For Power Big Endian: 7.0
- RedHat Enterprise Linux For Power Little Endian: 7.0
- RedHat Enterprise Linux For Scientific Computing: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
- RedHat Virtualization: 4.0
- RedHat Virtualization Host: 4.0
- RedHat Virtualization Manager: 4.3
- rsyslog: before 8.27.0 — fixed in 8.27.0
How to fix
Upgrade to a fixed version: rsyslog 8.27.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHBA-2019:2501
- https://access.redhat.com/errata/RHSA-2019:2110
- https://access.redhat.com/errata/RHSA-2019:2437
- https://access.redhat.com/errata/RHSA-2019:2439
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16881
- https://lists.debian.org/debian-lts-announce/2022/05/msg00028.html
- https://access.redhat.com/errata/RHBA-2019:2501
- https://access.redhat.com/errata/RHSA-2019:2110
- https://access.redhat.com/errata/RHSA-2019:2437
- https://access.redhat.com/errata/RHSA-2019:2439
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16881
- https://lists.debian.org/debian-lts-announce/2022/05/msg00028.html
Get alerted when CVE-2018-16881 or the next vulnerability affects your stack