What’s Vulnerable › Vulnerabilities
CVE-2018-16882
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-03 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free issue was found in the way the Linux kernel's KVM hypervisor processed posted interrupts when nested(=1) virtualization is enabled. In nested_get_vmcs12_pages(), in case of an error while processing posted interrupt address, it unmaps the 'pi_desc_page' without resetting 'pi_desc' descriptor address, which is later used in pi_test_and_clear_on(). A guest user/process could use this flaw to crash the host kernel resulting in DoS or potentially gain privileged access to a system. Kernel versions before 4.14.91 and before 4.19.13 are vulnerable.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Linux kernel: from 4.14 before 4.14.91; from 4.15 before 4.19.13 — fixed in 4.14.91, 4.19.13
How to fix
Upgrade to a fixed version: Linux kernel 4.14.91, 4.19.13. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106254
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16882
- https://lwn.net/Articles/775720/
- https://lwn.net/Articles/775721/
- https://marc.info/?l=kvm&m=154514994222809&w=2
- https://support.f5.com/csp/article/K80557033
- https://usn.ubuntu.com/3871-1/
- https://usn.ubuntu.com/3871-3/
- https://usn.ubuntu.com/3871-4/
- https://usn.ubuntu.com/3871-5/
- https://usn.ubuntu.com/3872-1/
- https://usn.ubuntu.com/3878-1/
Get alerted when CVE-2018-16882 or the next vulnerability affects your stack