What’s Vulnerable › Vulnerabilities

CVE-2018-16886

Description

etcd versions 3.2.x before 3.2.26 and 3.3.x before 3.3.11 are vulnerable to an improper authentication issue when role-based access control (RBAC) is used and client-cert-auth is enabled. If an etcd client server TLS certificate contains a Common Name (CN) which matches a valid RBAC username, a remote attacker may authenticate as that user with any valid (trusted) client certificate in a REST API request to the gRPC-gateway.

Affected products

How to fix

Upgrade to a fixed version: etcd-io etcd 3.2.26, 3.3.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-16886 or the next vulnerability affects your stack