What’s Vulnerable › Vulnerabilities
CVE-2018-16947
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-12 · updated 2026-06-17
- Weakness: CWE-287
Description
An issue was discovered in OpenAFS before 1.6.23 and 1.8.x before 1.8.2. The backup tape controller (butc) process accepts incoming RPCs but does not require (or allow for) authentication of those RPCs. Handling those RPCs results in operations being performed with administrator credentials, including dumping/restoring volume contents and manipulating the backup database. For example, an unauthenticated attacker can replace any volume's content with arbitrary data.
Affected products
- Debian Linux: 8.0, 9.0
- The OpenAFS Foundation OpenAFS: before 1.6.23; from 1.8.0 before 1.8.2 — fixed in 1.6.23, 1.8.2
How to fix
Upgrade to a fixed version: The OpenAFS Foundation OpenAFS 1.6.23, 1.8.2. Check the vendor advisory for mitigations.
References
- http://openafs.org/pages/security/OPENAFS-SA-2018-001.txt
- https://lists.debian.org/debian-lts-announce/2018/09/msg00024.html
- https://www.debian.org/security/2018/dsa-4302
- http://openafs.org/pages/security/OPENAFS-SA-2018-001.txt
- https://lists.debian.org/debian-lts-announce/2018/09/msg00024.html
- https://www.debian.org/security/2018/dsa-4302
Get alerted when CVE-2018-16947 or the next vulnerability affects your stack