What’s Vulnerable › Vulnerabilities
CVE-2018-16949
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-12 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue was discovered in OpenAFS before 1.6.23 and 1.8.x before 1.8.2. Several data types used as RPC input variables were implemented as unbounded array types, limited only by the inherent 32-bit length field to 4 GB. An unauthenticated attacker could send, or claim to send, large input values and consume server resources waiting for those inputs, denying service to other valid connections.
Affected products
- Debian Linux: 8.0, 9.0
- The OpenAFS Foundation OpenAFS: before 1.6.23; from 1.8.0 before 1.8.2 — fixed in 1.6.23, 1.8.2
How to fix
Upgrade to a fixed version: The OpenAFS Foundation OpenAFS 1.6.23, 1.8.2. Check the vendor advisory for mitigations.
References
- http://openafs.org/pages/security/OPENAFS-SA-2018-003.txt
- http://www.securityfocus.com/bid/106375
- https://lists.debian.org/debian-lts-announce/2018/09/msg00024.html
- https://www.debian.org/security/2018/dsa-4302
- http://openafs.org/pages/security/OPENAFS-SA-2018-003.txt
- http://www.securityfocus.com/bid/106375
- https://lists.debian.org/debian-lts-announce/2018/09/msg00024.html
- https://www.debian.org/security/2018/dsa-4302
Get alerted when CVE-2018-16949 or the next vulnerability affects your stack