What’s Vulnerable › Vulnerabilities
CVE-2018-16975
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-09-12 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue was discovered in Elefant CMS before 2.0.7. There is a PHP Code Execution Vulnerability in /designer/add/stylesheet.php by using a .php extension in the New Stylesheet Name field in conjunction with <?php content, because of insufficient input validation in apps/designer/handlers/csspreview.php.
Affected products
- Elefantcms Elefant: before 2.0.7 — fixed in 2.0.7
How to fix
Upgrade to a fixed version: Elefantcms Elefant 2.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/jbroadway/elefant/commit/0795ab57c7ffa53ff4af57e229f6d9680fa54a21
- https://github.com/jbroadway/elefant/issues/286
- https://github.com/jbroadway/elefant/releases/tag/elefant_2_0_7_stable
- https://github.com/jbroadway/elefant/commit/0795ab57c7ffa53ff4af57e229f6d9680fa54a21
- https://github.com/jbroadway/elefant/issues/286
- https://github.com/jbroadway/elefant/releases/tag/elefant_2_0_7_stable
Get alerted when CVE-2018-16975 or the next vulnerability affects your stack