What’s Vulnerable › Vulnerabilities
CVE-2018-16976
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-12 · updated 2026-06-17
- Weakness: CWE-362
Description
Gitolite before 3.6.9 does not (in certain configurations involving @all or a regex) properly restrict access to a Git repository that is in the process of being migrated until the full set of migration steps has been completed. This can allow valid users to obtain unintended access.
Affected products
- Gitolite: before 3.6.9 — fixed in 3.6.9
How to fix
Upgrade to a fixed version: Gitolite 3.6.9. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/908699
- https://github.com/sitaramc/gitolite/commit/dc13dfca8fdae5634bb0865f7e9822d2a268ed59
- https://groups.google.com/forum/#%21topic/gitolite-announce/WrwDTYdbfRg
- https://bugs.debian.org/908699
- https://github.com/sitaramc/gitolite/commit/dc13dfca8fdae5634bb0865f7e9822d2a268ed59
- https://groups.google.com/forum/#%21topic/gitolite-announce/WrwDTYdbfRg
Get alerted when CVE-2018-16976 or the next vulnerability affects your stack