What’s Vulnerable › Vulnerabilities

CVE-2018-17082

Description

The Apache2 component in PHP before 5.6.38, 7.0.x before 7.0.32, 7.1.x before 7.1.22, and 7.2.x before 7.2.10 allows XSS via the body of a "Transfer-Encoding: chunked" request, because the bucket brigade is mishandled in the php_handler function in sapi/apache2handler/sapi_apache2.c.

Affected products

How to fix

Upgrade to a fixed version: PHP 5.6.38, 7.0.32, 7.1.22, 7.2.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-17082 or the next vulnerability affects your stack