What’s Vulnerable › Vulnerabilities

CVE-2018-17145

Description

Bitcoin Core 0.16.x before 0.16.2 and Bitcoin Knots 0.16.x before 0.16.2 allow remote denial of service via a flood of multiple transaction inv messages with random hashes, aka INVDoS. NOTE: this can also affect other cryptocurrencies, e.g., if they were forked from Bitcoin Core after 2017-11-15.

Affected products

How to fix

Upgrade to a fixed version: Bcoin 1.0.2; Bitcoin Core 0.16.2; Bitcoinknots Bitcoin Knots 0.16.2; Decred Dcrd 1.5.2; Litecoin 0.16.2; Namecoin Core 0.16.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-17145 or the next vulnerability affects your stack