What’s Vulnerable › Vulnerabilities
CVE-2018-17146
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-19 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting vulnerability exists in Nagios XI before 5.5.4 via the 'name' parameter within the Account Information page. Exploitation of this vulnerability allows an attacker to execute arbitrary JavaScript code within the auto login admin management page.
Affected products
- Nagios XI: before 5.5.4 — fixed in 5.5.4
How to fix
Upgrade to a fixed version: Nagios XI 5.5.4. Check the vendor advisory for mitigations.
References
- https://assets.nagios.com/downloads/nagiosxi/CHANGES-5.TXT
- https://assets.nagios.com/downloads/nagiosxi/CHANGES-5.TXT
Get alerted when CVE-2018-17146 or the next vulnerability affects your stack