What’s Vulnerable › Vulnerabilities
CVE-2018-17148
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-19 · updated 2026-06-17
- Weakness: CWE-284
Description
An Insufficient Access Control vulnerability (leading to credential disclosure) in coreconfigsnapshot.php (aka configuration snapshot page) in Nagios XI before 5.5.4 allows remote attackers to gain access to configuration files containing confidential credentials.
Affected products
- Nagios XI: before 5.5.4 — fixed in 5.5.4
How to fix
Upgrade to a fixed version: Nagios XI 5.5.4. Check the vendor advisory for mitigations.
References
- https://assets.nagios.com/downloads/nagiosxi/CHANGES-5.TXT
- https://assets.nagios.com/downloads/nagiosxi/CHANGES-5.TXT
Get alerted when CVE-2018-17148 or the next vulnerability affects your stack