What’s Vulnerable › Vulnerabilities
CVE-2018-17158
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-04 · updated 2026-06-17
- Weakness: CWE-190
Description
In FreeBSD before 11.2-STABLE(r340854) and 11.2-RELEASE-p5, an integer overflow error can occur when handling the client address length field in an NFSv4 request. Unprivileged remote users with access to the NFS server can crash the system by sending a specially crafted NFSv4 request.
Affected products
- FreeBSD: before 11.2; 11.2-p5 — fixed in 11.2
How to fix
Upgrade to a fixed version: FreeBSD 11.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106192
- http://www.securitytracker.com/id/1042164
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-24/
- https://security.freebsd.org/advisories/FreeBSD-SA-18:13.nfs.asc
- http://www.securityfocus.com/bid/106192
- http://www.securitytracker.com/id/1042164
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-24/
- https://security.freebsd.org/advisories/FreeBSD-SA-18:13.nfs.asc
Get alerted when CVE-2018-17158 or the next vulnerability affects your stack