What’s Vulnerable › Vulnerabilities
CVE-2018-17160
- Severity: critical (CVSS 10.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-04 · updated 2026-06-17
- Weakness: CWE-787
Description
In FreeBSD before 11.2-STABLE(r341486) and 11.2-RELEASE-p6, insufficient bounds checking in one of the device models provided by bhyve can permit a guest operating system to overwrite memory in the bhyve host possibly permitting arbitrary code execution. A guest OS using a firmware image can cause the bhyve process to crash, or possibly execute arbitrary code on the host as root.
Affected products
- FreeBSD: before 11.2; 11.2-p5 — fixed in 11.2
How to fix
Upgrade to a fixed version: FreeBSD 11.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106210
- https://security.freebsd.org/advisories/FreeBSD-SA-18:14.bhyve.asc
- http://www.securityfocus.com/bid/106210
- https://security.freebsd.org/advisories/FreeBSD-SA-18:14.bhyve.asc
Get alerted when CVE-2018-17160 or the next vulnerability affects your stack