What’s Vulnerable › Vulnerabilities
CVE-2018-17170
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-28 · updated 2026-06-17
- Weakness: CWE-94
Description
Grouptime Teamwire Desktop Client 1.5.1 prior to 1.9.0 on Windows allows code injection via a template, leading to remote code execution. All backend versions prior to prod-2018-11-13-15-00-42 are affected.
Affected products
- Teamwire: from 1.5.1 before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Teamwire 1.9.0. Check the vendor advisory for mitigations.
References
- https://research.hisolutions.com/2019/06/web-vulnerabilities-are-coming-to-the-desktop-template-injections-lead-to-rce-in-teamwire/
- https://research.hisolutions.com/2019/06/web-vulnerabilities-are-coming-to-the-desktop-template-injections-lead-to-rce-in-teamwire/
Get alerted when CVE-2018-17170 or the next vulnerability affects your stack