What’s Vulnerable › Vulnerabilities
CVE-2018-17182
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-09-19 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the Linux kernel through 4.18.8. The vmacache_flush_all function in mm/vmacache.c mishandles sequence number overflows. An attacker can trigger a use-after-free (and possibly gain privileges) via certain thread creation, map, unmap, invalidation, and dereference operations.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Linux kernel: from 3.16 before 3.16.58; from 3.17 before 3.18.123; from 3.19 before 4.4.157; from 4.5 before 4.9.128; from 4.10 before 4.14.71; from 4.15 before 4.18.9 — fixed in 3.16.58, 3.18.123, 4.14.71, 4.18.9, 4.4.157, 4.9.128
- NetApp Active Iq Performance Analytics Services: all versions
- NetApp Element Software: all versions
How to fix
Upgrade to a fixed version: Linux kernel 3.16.58, 3.18.123, 4.14.71, 4.18.9. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=7a9cdebdcc17e426fb5287e4a82db1dfe86339b2
- http://www.securityfocus.com/bid/105417
- http://www.securityfocus.com/bid/106503
- http://www.securitytracker.com/id/1041748
- https://access.redhat.com/errata/RHSA-2018:3656
- https://github.com/torvalds/linux/commit/7a9cdebdcc17e426fb5287e4a82db1dfe86339b2
- https://lists.debian.org/debian-lts-announce/2018/10/msg00003.html
- https://security.netapp.com/advisory/ntap-20190204-0001/
- https://usn.ubuntu.com/3776-1/
- https://usn.ubuntu.com/3776-2/
- https://usn.ubuntu.com/3777-1/
- https://usn.ubuntu.com/3777-2/
Get alerted when CVE-2018-17182 or the next vulnerability affects your stack