What’s Vulnerable › Vulnerabilities
CVE-2018-17183
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-19 · updated 2026-06-17
Description
Artifex Ghostscript before 9.25 allowed a user-writable error exception table, which could be used by remote attackers able to supply crafted PostScript to potentially overwrite or replace error handlers to inject code.
Affected products
- Artifex Ghostscript: before 9.25 — fixed in 9.25
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.25. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=fb713b3818b52d8a6cf62c951eba2e1795ff9624
- https://access.redhat.com/errata/RHSA-2018:3834
- https://bugs.ghostscript.com/show_bug.cgi?id=699708
- https://lists.debian.org/debian-lts-announce/2018/09/msg00038.html
- https://usn.ubuntu.com/3773-1/
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=fb713b3818b52d8a6cf62c951eba2e1795ff9624
- https://access.redhat.com/errata/RHSA-2018:3834
- https://bugs.ghostscript.com/show_bug.cgi?id=699708
- https://lists.debian.org/debian-lts-announce/2018/09/msg00038.html
- https://usn.ubuntu.com/3773-1/
Get alerted when CVE-2018-17183 or the next vulnerability affects your stack