What’s Vulnerable › Vulnerabilities
CVE-2018-17184
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
A malicious user with enough administration entitlements can inject html-like elements containing JavaScript statements into Connector names, Report names, AnyTypeClass keys and Policy descriptions. When another user with enough administration entitlements edits one of the Entities above via Admin Console, the injected JavaScript code is executed.
Affected products
- Apache Software Foundation Apache Syncope: from 2.0.0 before 2.0.11; from 2.1.0 before 2.1.2 — fixed in 2.0.11, 2.1.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Syncope 2.0.11, 2.1.2. Check the vendor advisory for mitigations.
References
- https://syncope.apache.org/security#CVE-2018-17184:_Stored_XSS
- https://syncope.apache.org/security#CVE-2018-17184:_Stored_XSS
Get alerted when CVE-2018-17184 or the next vulnerability affects your stack