What’s Vulnerable › Vulnerabilities
CVE-2018-17207
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 60.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-09-19 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue was discovered in Snap Creek Duplicator before 1.2.42. By accessing leftover installer files (installer.php and installer-backup.php), an attacker can inject PHP code into wp-config.php during the database setup step, achieving arbitrary code execution.
Affected products
- Duplicator: before 1.2.42 — fixed in 1.2.42
How to fix
Upgrade to a fixed version: Duplicator 1.2.42. Check the vendor advisory for mitigations.
References
- https://snapcreek.com/duplicator/docs/changelog/?lite
- https://www.synacktiv.com/ressources/advisories/WordPress_Duplicator-1.2.40-RCE.pdf
- https://snapcreek.com/duplicator/docs/changelog/?lite
- https://www.synacktiv.com/ressources/advisories/WordPress_Duplicator-1.2.40-RCE.pdf
Get alerted when CVE-2018-17207 or the next vulnerability affects your stack