What’s Vulnerable › Vulnerabilities
CVE-2018-17294
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-09-21 · updated 2026-06-17
- Weakness: CWE-125
Description
The matchCurrentInput function inside lou_translateString.c of Liblouis prior to 3.7 does not check the input string's length, allowing attackers to cause a denial of service (application crash via out-of-bounds read) by crafting an input file with certain translation dictionaries.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- liblouis: before 3.7.0 — fixed in 3.7.0
- openSUSE Leap: 15.0
How to fix
Upgrade to a fixed version: liblouis 3.7.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00038.html
- http://www.securityfocus.com/bid/105511
- https://github.com/liblouis/liblouis/commit/5e4089659bb49b3095fa541fa6387b4c40d7396e
- https://github.com/liblouis/liblouis/issues/635
- https://usn.ubuntu.com/3782-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00038.html
- http://www.securityfocus.com/bid/105511
- https://github.com/liblouis/liblouis/commit/5e4089659bb49b3095fa541fa6387b4c40d7396e
- https://github.com/liblouis/liblouis/issues/635
- https://usn.ubuntu.com/3782-1/
Get alerted when CVE-2018-17294 or the next vulnerability affects your stack