What’s Vulnerable › Vulnerabilities
CVE-2018-17456
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 97.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-06 · updated 2026-06-17
- Weakness: CWE-88
Description
Git before 2.14.5, 2.15.x before 2.15.3, 2.16.x before 2.16.5, 2.17.x before 2.17.2, 2.18.x before 2.18.1, and 2.19.x before 2.19.1 allows remote code execution during processing of a recursive "git clone" of a superproject if a .gitmodules file has a URL field beginning with a '-' character.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 9.0
- git: from 2.14.0 before 2.14.5; from 2.15.0 before 2.15.3; from 2.16.0 before 2.16.5; from 2.17.0 before 2.17.2; from 2.18.0 before 2.18.1; from 2.19.0 before 2.19.1 — fixed in 2.14.5, 2.15.3, 2.16.5, 2.17.2, 2.18.1, 2.19.1
- Tower: 3.3
- Red Hat Enterprise Linux: 6.0, 6.7, 7.0, 7.3, 7.4, 7.5 (+1)
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: git 2.14.5, 2.15.3, 2.16.5, 2.17.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00003.html
- http://packetstormsecurity.com/files/152173/Sourcetree-Git-Arbitrary-Code-Execution-URL-Handling.html
- http://www.securityfocus.com/bid/105523
- http://www.securityfocus.com/bid/107511
- http://www.securitytracker.com/id/1041811
- https://access.redhat.com/errata/RHSA-2018:3408
- https://access.redhat.com/errata/RHSA-2018:3505
- https://access.redhat.com/errata/RHSA-2018:3541
- https://access.redhat.com/errata/RHSA-2020:0316
- https://github.com/git/git/commit/1a7fd1fb2998002da6e9ff2ee46e1bdd25ee8404
- https://github.com/git/git/commit/a124133e1e6ab5c7a9fef6d0e6bcb084e3455b46
- https://marc.info/?l=git&m=153875888916397&w=2
Get alerted when CVE-2018-17456 or the next vulnerability affects your stack