What’s Vulnerable › Vulnerabilities
CVE-2018-17537
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-16 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in GitLab Community and Enterprise Edition before 11.1.7, 11.2.x before 11.2.4, and 11.3.x before 11.3.1. blog-viewer has stored XSS during repository browsing, if package.json exists. .
Affected products
- GitLab: before 11.1.7; from 11.2.0 before 11.2.4; 11.3.0 — fixed in 11.1.7, 11.2.4
How to fix
Upgrade to a fixed version: GitLab 11.1.7, 11.2.4. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/blog/categories/releases/
- https://about.gitlab.com/releases/2018/10/01/security-release-gitlab-11-dot-3-dot-1-released/
- https://about.gitlab.com/blog/categories/releases/
- https://about.gitlab.com/releases/2018/10/01/security-release-gitlab-11-dot-3-dot-1-released/
Get alerted when CVE-2018-17537 or the next vulnerability affects your stack