What’s Vulnerable › Vulnerabilities
CVE-2018-17540
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-03 · updated 2026-06-17
- Weakness: CWE-119
Description
The gmp plugin in strongSwan before 5.7.1 has a Buffer Overflow via a crafted certificate.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- strongSwan: before 5.7.1 — fixed in 5.7.1
How to fix
Upgrade to a fixed version: strongSwan 5.7.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00047.html
- https://download.strongswan.org/security/CVE-2018-17540/
- https://lists.debian.org/debian-lts-announce/2018/10/msg00001.html
- https://security.gentoo.org/glsa/201811-16
- https://usn.ubuntu.com/3774-1/
- https://www.debian.org/security/2018/dsa-4309
- https://www.strongswan.org/blog/2018/10/01/strongswan-vulnerability-%28cve-2018-17540%29.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00077.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00047.html
Get alerted when CVE-2018-17540 or the next vulnerability affects your stack