What’s Vulnerable › Vulnerabilities
CVE-2018-17610
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-28 · updated 2026-06-17
- Weakness: CWE-416
Description
Foxit PhantomPDF and Reader before 9.3 allow remote attackers to execute arbitrary code or cause a denial of service (use-after-free) because properties of Annotation objects are mishandled. This relates to one of five distinct types of Annotation objects.
Affected products
- Foxit PhantomPDF: before 9.3 — fixed in 9.3
- Foxit Reader: before 9.3 — fixed in 9.3
How to fix
Upgrade to a fixed version: Foxit PhantomPDF 9.3; Foxit Reader 9.3. Check the vendor advisory for mitigations.
References
- https://www.foxitsoftware.com/support/security-bulletins.php
- https://www.foxitsoftware.com/support/security-bulletins.php
Get alerted when CVE-2018-17610 or the next vulnerability affects your stack