What’s Vulnerable › Vulnerabilities
CVE-2018-17614
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-13 · updated 2026-06-17
- Weakness: CWE-121
Description
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Losant Arduino MQTT Client prior to V2.7. User interaction is not required to exploit this vulnerability. The specific flaw exists within the parsing of MQTT PUBLISH packets. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-6436.
Affected products
- Losant Arduino MQTT Client: before 2.7 — fixed in 2.7
How to fix
Upgrade to a fixed version: Losant Arduino MQTT Client 2.7. Check the vendor advisory for mitigations.
References
- https://github.com/knolleary/pubsubclient/releases/tag/v2.7
- https://zerodayinitiative.com/advisories/ZDI-18-1337
- https://github.com/knolleary/pubsubclient/releases/tag/v2.7
- https://zerodayinitiative.com/advisories/ZDI-18-1337
Get alerted when CVE-2018-17614 or the next vulnerability affects your stack