What’s Vulnerable › Vulnerabilities
CVE-2018-17707
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-24 · updated 2026-06-17
- Weakness: CWE-78
Description
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Epic Games Launcher versions prior to 8.2.2. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handler for the com.epicgames.launcher protocol. A crafted URI with the com.epicgames.launcher protocol can trigger execution of a system call composed from a user-supplied string. An attacker can leverage this vulnerability to execute code in the context of the current user. Was ZDI-CAN-7241.
Affected products
- Epic Games Launcher: before 8.2.2 — fixed in 8.2.2
How to fix
Upgrade to a fixed version: Epic Games Launcher 8.2.2. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-18-1359/
- https://www.zerodayinitiative.com/advisories/ZDI-18-1359/
Get alerted when CVE-2018-17707 or the next vulnerability affects your stack