What’s Vulnerable › Vulnerabilities
CVE-2018-17884
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-02 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS exists in admin/gb-dashboard-widget.php in the Gwolle Guestbook (gwolle-gb) plugin before 2.5.4 for WordPress via the PATH_INFO to wp-admin/index.php
Affected products
- Gwolle Guestbook Plugin: before 2.5.4 — fixed in 2.5.4
How to fix
Upgrade to a fixed version: Gwolle Guestbook Plugin 2.5.4. Check the vendor advisory for mitigations.
References
- http://www.defensecode.com/advisories/DC-2018-05-008_WordPress_Gwolle_Guestbook_Plugin_Advisory.pdf
- https://seclists.org/bugtraq/2018/Jul/74
- https://wordpress.org/plugins/gwolle-gb/#developers
- http://www.defensecode.com/advisories/DC-2018-05-008_WordPress_Gwolle_Guestbook_Plugin_Advisory.pdf
- https://seclists.org/bugtraq/2018/Jul/74
- https://wordpress.org/plugins/gwolle-gb/#developers
Get alerted when CVE-2018-17884 or the next vulnerability affects your stack