What’s Vulnerable › Vulnerabilities
CVE-2018-17939
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-12-04 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was discovered in GitLab Community and Enterprise Edition 11.1.x before 11.1.8, 11.2.x before 11.2.5, and 11.3.x before 11.3.2. There is Information Exposure via the merge request JSON endpoint.
Affected products
- GitLab: from 11.1.0 before 11.1.8; from 11.2.0 before 11.2.5; from 11.3.0 before 11.3.2 — fixed in 11.1.8, 11.2.5, 11.3.2
How to fix
Upgrade to a fixed version: GitLab 11.1.8, 11.2.5, 11.3.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/10/05/critical-security-release-11-3-4/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/51956
- https://about.gitlab.com/2018/10/05/critical-security-release-11-3-4/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/51956
Get alerted when CVE-2018-17939 or the next vulnerability affects your stack