What’s Vulnerable › Vulnerabilities
CVE-2018-17961
- Severity: high (CVSS 8.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-15 · updated 2026-06-17
- Weakness: CWE-209
Description
Artifex Ghostscript 9.25 and earlier allows attackers to bypass a sandbox protection mechanism via vectors involving errorhandler setup. NOTE: this issue exists because of an incomplete fix for CVE-2018-17183.
Affected products
- Artifex Ghostscript: before 9.25 — fixed in 9.25
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 9.25. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=a54c9e61e7d0
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=a5a9bf8c6a63
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=a6807394bd94
- http://www.openwall.com/lists/oss-security/2018/10/09/4
- https://access.redhat.com/errata/RHSA-2018:3834
- https://bugs.chromium.org/p/project-zero/issues/detail?id=1682&desc=2
- https://bugs.ghostscript.com/show_bug.cgi?id=699816
- https://lists.debian.org/debian-lts-announce/2018/10/msg00013.html
- https://usn.ubuntu.com/3803-1/
- https://www.debian.org/security/2018/dsa-4336
- https://www.exploit-db.com/exploits/45573/
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=a54c9e61e7d0
Get alerted when CVE-2018-17961 or the next vulnerability affects your stack