What’s Vulnerable › Vulnerabilities
CVE-2018-18021
- Severity: high (CVSS 7.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-07 · updated 2026-06-17
- Weakness: CWE-20
Description
arch/arm64/kvm/guest.c in KVM in the Linux kernel before 4.18.12 on the arm64 platform mishandles the KVM_SET_ON_REG ioctl. This is exploitable by attackers who can create virtual machines. An attacker can arbitrarily redirect the hypervisor flow of control (with full register control). An attacker can also cause a denial of service (hypervisor panic) via an illegal exception return. This occurs because of insufficient restrictions on userspace access to the core register file, and because PSTATE.M validation does not prevent unintended execution modes.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Debian Linux: 9.0
- Linux kernel: before 4.18.12 — fixed in 4.18.12
How to fix
Upgrade to a fixed version: Linux kernel 4.18.12. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2a3f93459d689d990b3ecfbe782fec89b97d3279
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d26c25a9d19b5976b319af528886f89cf455692d
- http://www.securityfocus.com/bid/105550
- https://access.redhat.com/errata/RHSA-2018:3656
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.18.12
- https://github.com/torvalds/linux/commit/2a3f93459d689d990b3ecfbe782fec89b97d3279
- https://github.com/torvalds/linux/commit/d26c25a9d19b5976b319af528886f89cf455692d
- https://usn.ubuntu.com/3821-1/
- https://usn.ubuntu.com/3821-2/
- https://usn.ubuntu.com/3931-1/
- https://usn.ubuntu.com/3931-2/
- https://www.debian.org/security/2018/dsa-4313
Get alerted when CVE-2018-18021 or the next vulnerability affects your stack