What’s Vulnerable › Vulnerabilities
CVE-2018-18074
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-09 · updated 2026-06-17
- Weakness: CWE-522
Description
The Requests package before 2.20.0 for Python sends an HTTP Authorization header to an http URI upon receiving a same-hostname https-to-http redirect, which makes it easier for remote attackers to discover credentials by sniffing the network.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- openSUSE Leap: 15.1
- psf requests: before 2.20.0 — fixed in 2.20.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: psf requests 2.20.0. Check the vendor advisory for mitigations.
References
- http://docs.python-requests.org/en/master/community/updates/#release-and-version-history
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00024.html
- https://access.redhat.com/errata/RHSA-2019:2035
- https://bugs.debian.org/910766
- https://github.com/requests/requests/commit/c45d7c49ea75133e52ab22a8e9e13173938e36ff
- https://github.com/requests/requests/issues/4716
- https://github.com/requests/requests/pull/4718
- https://usn.ubuntu.com/3790-1/
- https://usn.ubuntu.com/3790-2/
- https://www.oracle.com/security-alerts/cpujul2022.html
- http://docs.python-requests.org/en/master/community/updates/#release-and-version-history
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00024.html
Get alerted when CVE-2018-18074 or the next vulnerability affects your stack