What’s Vulnerable › Vulnerabilities
CVE-2018-18284
- Severity: high (CVSS 8.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-10-19 · updated 2026-06-17
Description
Artifex Ghostscript 9.25 and earlier allows attackers to bypass a sandbox protection mechanism via vectors involving the 1Policy operator.
Affected products
- Artifex Ghostscript: through 9.25
- Artifex Gpl Ghostscript: before 9.26 — fixed in 9.26
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Ivanti Connect Secure (Pulse Secure): from 8.2r1.0 before 8.2r12.1; from 8.3r1 before 8.3r7.1; from 9.0r1 before 9.0r3.4 — fixed in 8.2r12.1, 8.3r7.1, 9.0r3.4
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Artifex Gpl Ghostscript 9.26; Ivanti Connect Secure (Pulse Secure) 8.2r12.1, 8.3r7.1, 9.0r3.4. Check the vendor advisory for mitigations.
References
- http://git.ghostscript.com/?p=ghostpdl.git%3Bh=8d19fdf63f91f50466b08f23e2d93d37a4c5ea0b
- http://www.openwall.com/lists/oss-security/2018/10/16/2
- http://www.securityfocus.com/bid/107451
- https://access.redhat.com/errata/RHSA-2018:3834
- https://bugs.chromium.org/p/project-zero/issues/detail?id=1696
- https://bugs.ghostscript.com/show_bug.cgi?id=699963
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44101
- https://lists.debian.org/debian-lts-announce/2018/10/msg00013.html
- https://security.gentoo.org/glsa/201811-12
- https://support.f5.com/csp/article/K22141757?utm_source=f5support&%3Butm_medium=RSS
- https://usn.ubuntu.com/3803-1/
- https://www.debian.org/security/2018/dsa-4336
Get alerted when CVE-2018-18284 or the next vulnerability affects your stack